<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"/><link type="text/css" media="all" href="https://dotesports.com/wp-content/cache/autoptimize/1/css/autoptimize_704f6578ef83e0a68b73e90c12c58e8f.css" rel="stylesheet" /><title>Call of Duty Mobile soft-launched in Australia and Canada with more regions coming soon | Dot Esports</title> <script type='text/javascript' async=true>var elem = document.createElement('script');
        elem.src = 'https://quantcast.mgr.consensu.org/cmp.js';
        elem.async = true;
        elem.type = 'text/javascript';
        var scpt = document.getElementsByTagName('script')[0];
        scpt.parentNode.insertBefore(elem, scpt);
        (function() {
        var gdprAppliesGlobally = false;
        function addFrame() {
            if (!window.frames['__cmpLocator']) {
            if (document.body) {
                var body = document.body,
                    iframe = document.createElement('iframe');
                iframe.style = 'display:none';
                iframe.name = '__cmpLocator';
                body.appendChild(iframe);
            } else {
                // In the case where this stub is located in the head,
                // this allows us to inject the iframe more quickly than
                // relying on DOMContentLoaded or other events.
                setTimeout(addFrame, 5);
            }
            }
        }
        addFrame();
        function cmpMsgHandler(event) {
            var msgIsString = typeof event.data === 'string';
            var json;
            if(msgIsString) {
            json = event.data.indexOf('__cmpCall') != -1 ? JSON.parse(event.data) : {};
            } else {
            json = event.data;
            }
            if (json.__cmpCall) {
            var i = json.__cmpCall;
            window.__cmp(i.command, i.parameter, function(retValue, success) {
                var returnMsg = {'__cmpReturn': {
                'returnValue': retValue,
                'success': success,
                'callId': i.callId
                }};
                event.source.postMessage(msgIsString ?
                JSON.stringify(returnMsg) : returnMsg, '*');
            });
            }
        }
        window.__cmp = function (c) {
            var b = arguments;
            if (!b.length) {
            return __cmp.a;
            }
            else if (b[0] === 'ping') {
            b[2]({'gdprAppliesGlobally': gdprAppliesGlobally,
                'cmpLoaded': false}, true);
            } else if (c == '__cmp')
            return false;
            else {
            if (typeof __cmp.a === 'undefined') {
                __cmp.a = [];
            }
            __cmp.a.push([].slice.apply(b));
            }
        }
        window.__cmp.gdprAppliesGlobally = gdprAppliesGlobally;
        window.__cmp.msgHandler = cmpMsgHandler;
        if (window.addEventListener) {
            window.addEventListener('message', cmpMsgHandler, false);
        }
        else {
            window.attachEvent('onmessage', cmpMsgHandler);
        }
        })();
        window.__cmp('init', {
                'Language': 'en',
            'Initial Screen Reject Button Text': 'I do not accept',
            'Initial Screen Accept Button Text': 'I accept',
            'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
            'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
            'Vendor Screen Accept All Button Text': 'Accept all',
            'Vendor Screen Reject All Button Text': 'Reject all',
            'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
            'Initial Screen Body Text Option': 1,
            'Publisher Name': 'Dot Esports',
            'Publisher Logo': 'https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11085710/logo-dot_esports-h-white.png',
            'Min Days Between UI Displays': 15,
            'Publisher Purpose IDs': [1,2,3,4,5],
            'Post Consent Page': 'https://www.google.com/',
            'UI Layout': 'banner',
        });</script><script type="text/javascript" src="//d1f1ahf99nq0ja.cloudfront.net/script.js"></script><script>var special_ops=special_ops||{}</script><script>special_ops.page_type = "home"</script><script>special_ops.tags = ["call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon", "call-of-duty","mobile"]</script> <script src='https://cdnjs.cloudflare.com/ajax/libs/postscribe/2.0.8/postscribe.min.js'></script> <script>var propertag = propertag || {};
        propertag.cmd = propertag.cmd || [];
        (function() {
        var pm = document.createElement('script');
        pm.async = true; pm.type = 'text/javascript';
        var is_ssl = 'https:' == document.location.protocol;
        pm.src = (is_ssl ? 'https:' : 'http:') + '//global.proper.io/dotesports.min.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(pm, node);
        })();</script> <script>/* You can add more configuration options to webfontloader by previously defining the WebFontConfig with your options */
                            if ( typeof WebFontConfig === "undefined" ) {
                                WebFontConfig = new Object();
                            }
                            WebFontConfig['google'] = {families: ['Montserrat:100,200,300,400,500,600,700,800,900,100italic,200italic,300italic,400italic,500italic,600italic,700italic,800italic,900italic', 'Source+Serif+Pro:400']};

                            (function() {
                                var wf = document.createElement( 'script' );
                                wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
                                wf.type = 'text/javascript';
                                wf.async = 'true';
                                var s = document.getElementsByTagName( 'script' )[0];
                                s.parentNode.insertBefore( wf, s );
                            })();</script>  <script data-cfasync="false" type="text/javascript">//
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//</script> <link rel="canonical" href="https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Call of Duty Mobile soft-launched in Australia and Canada with more regions coming soon | Dot Esports" /><meta property="og:description" content="The game has finally been released." /><meta property="og:url" content="https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon" /><meta property="og:site_name" content="Dot Esports" /><meta property="article:section" content="Mobile" /><meta property="article:published_time" content="2019-07-21T01:59:52+00:00" /><meta property="article:modified_time" content="2019-07-21T01:59:57+00:00" /><meta property="og:updated_time" content="2019-07-21T01:59:57+00:00" /><meta property="fb:app_id" content="1218020374973612" /><meta property="og:image" content="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2019/07/20205349/fgjh.jpg" /><meta property="og:image:secure_url" content="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2019/07/20205349/fgjh.jpg" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="1080" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="The game has finally been released." /><meta name="twitter:title" content="Call of Duty Mobile soft-launched in Australia and Canada with more regions coming soon | Dot Esports" /><meta name="twitter:image" content="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2019/07/20205349/fgjh.jpg" /><meta name="twitter:creator" content="@wasifahd_" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://dotesports.com/#website","url":"https://dotesports.com/","name":"Dot Esports","potentialAction":{"@type":"SearchAction","target":"https://dotesports.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon#primaryimage","url":"https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2019/07/20205349/fgjh.jpg","width":1920,"height":1080},{"@type":"WebPage","@id":"https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon#webpage","url":"https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon","inLanguage":"en-US","name":"Call of Duty Mobile soft-launched in Australia and Canada with more regions coming soon | Dot Esports","isPartOf":{"@id":"https://dotesports.com/#website"},"primaryImageOfPage":{"@id":"https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon#primaryimage"},"datePublished":"2019-07-21T01:59:52+00:00","dateModified":"2019-07-21T01:59:57+00:00","author":{"@id":"https://dotesports.com/#/schema/person/a1de957ad5e6d2851b0b1098f5fd87b5"}},{"@type":["Person"],"@id":"https://dotesports.com/#/schema/person/a1de957ad5e6d2851b0b1098f5fd87b5","name":"Wasif Ahmed","image":{"@type":"ImageObject","@id":"https://dotesports.com/#authorlogo","url":"https://secure.gravatar.com/avatar/871442c3d1eb769ff2ebd91dcda9c67e?s=96&d=mm&r=g","caption":"Wasif Ahmed"},"description":"I love writing and gaming, so here I am. Mainly covering mobile esports.","sameAs":["https://twitter.com/wasifahd_"]}]}</script> <link rel='dns-prefetch' href='//dotesports.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Dot Esports &raquo; Feed" href="https://dotesports.com/feed" /> <script>!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://forecasttiger.com/v2/0/dpqKWHOMb25HMlIJz2PkgVUBKU2o5BORqXZQf8tMVyf3MrAM-rruv0Kk2fSy6vguDmh2H3H7bjF2r-7YcMk9Q",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,n,e,o){function r(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(n){}return!1}function c(){var o=r();if(o){var c=t[n].pubads();typeof c.setTargeting===e&&c.setTargeting("admiral-engaged","true")}}o=t[n]=t[n]||{},o.cmd=o.cmd||[],typeof o.pubads===e?c():typeof o.cmd.unshift===e?o.cmd.unshift(c):o.cmd.push(c)}(window,"googletag","function");;;;;</script><script type='text/javascript'>var rever_script_data = {"gif_auto":"0","slider_auto":"","slider_delay":"3000"};</script> <script type='text/javascript' src='https://dotesports.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://dotesports.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/dotesports-gallery/public/lib/flickity/flickity.pkgd.min.js?ver=2.2.0'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/dotesports-gallery/public/lib/flickity/hash.js?ver=1.0.3'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/dotesports-gallery/public/lib/photoswipe/photoswipe.min.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/dotesports-gallery/public/lib/photoswipe/photoswipe-ui-default.min.js?ver=5.2.2'></script> <script type='text/javascript'>var mobileCarouselAd = "<div id=\"proper-ad-dotesports_content_6\" data-properslot=\"dotesports_content_6\"><\/div>";
var desktopCarouselAd = "<div id=\"proper-ad-dotesports_content_6\" data-properslot=\"dotesports_content_6\"><\/div>";</script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/dotesports-gallery/public/js/dotgallery-public.js?ver=dotgallery'></script> <script type='text/javascript'>var wpp_params = {"sampling_active":"1","sampling_rate":"100","ajax_url":"https:\/\/dotesports.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"153840","token":"d37a331531","debug":""};</script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.9.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/functions.js?ver=5.0.1'></script> <!--[if lt IE 9]> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/html5.js?ver=3.6.0'></script> <![endif]--> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/jquery.magnific-popup.min.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/js.cookie.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/waves-script.js?ver=5.2.2'></script> <link rel='https://api.w.org/' href='https://dotesports.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dotesports.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dotesports.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.2" /><link rel='shortlink' href='https://wp.me/paesOB-E1i' /><link rel="alternate" type="application/json+oembed" href="https://dotesports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdotesports.com%2Fnews%2Fcall-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon" /><link rel="alternate" type="text/xml+oembed" href="https://dotesports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdotesports.com%2Fnews%2Fcall-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon&#038;format=xml" />  <script type="application/ld+json">{"@context":"http:\/\/schema.org\/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/dotesports.com\/news\/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon"},"url":"https:\/\/dotesports.com\/news\/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon","headline":"Call of Duty Mobile soft-launched in Australia and Canada with more regions coming...","datePublished":"2019-07-20T20:59:52-05:00","dateModified":"2019-07-20T20:59:57+00:00","publisher":{"@type":"Organization","@id":"https:\/\/dotesports.com\/#organization","name":"Dot Esports","logo":{"@type":"ImageObject","url":"https:\/\/dotesports-media.nyc3.cdn.digitaloceanspaces.com\/wp-content\/uploads\/2018\/12\/13191656\/dotesports-amp.png","width":600,"height":60}},"image":{"@type":"ImageObject","url":"https:\/\/dotesports-media.nyc3.cdn.digitaloceanspaces.com\/wp-content\/uploads\/2019\/07\/20205349\/fgjh.jpg","width":1920,"height":1080},"articleSection":"Call of Duty","description":"The game has finally been released. ","author":{"@type":"Person","name":"Wasif Ahmed","url":"https:\/\/dotesports.com\/author\/wasifahmed","description":"I love writing and gaming, so here I am. Mainly covering mobile esports.","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/871442c3d1eb769ff2ebd91dcda9c67e?s=96&d=mm&r=g","height":96,"width":96},"sameAs":["https:\/\/twitter.com\/wasifahd_"]}}</script>  <script data-cfasync="false" type="text/javascript">//
	dataLayer.push({"siteID":"1","siteName":"Dot Esports","visitorLoginState":"logged-out","pageTitle":"Call of Duty Mobile soft-launched in Australia and Canada with more regions coming soon | Dot Esports","pagePostType":"post","pagePostType2":"single-post","pageCategory":["call-of-duty","mobile"],"pagePostAuthorID":1743,"pagePostAuthor":"Wasif Ahmed","pagePostDate":"July 20, 2019","pagePostDateYear":"2019","pagePostDateMonth":"07","pagePostDateDay":"20","deviceType":"desktop","deviceManufacturer":"Apple","deviceModel":"Macintosh","postID":153840,"postFormat":"standard"});//</script> <script data-cfasync="false">//
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WDR623V');//</script> <link rel='dns-prefetch' href='//v0.wordpress.com'/><link rel='dns-prefetch' href='//c0.wp.com'/> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="amphtml" href="https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon/amp"><link rel="icon" href="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11090538/cropped-logo-dot_esports-mark-black-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11090538/cropped-logo-dot_esports-mark-black-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11090538/cropped-logo-dot_esports-mark-black-1-180x180.png" /><meta name="msapplication-TileImage" content="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11090538/cropped-logo-dot_esports-mark-black-1-270x270.png" /></head><body class="post-template-default single single-post postid-153840 single-format-standard"><div class="tw-mobile-menu"><div class="tw-logo"><a class="logo " href="https://dotesports.com/"><img class="logo-img" srcset="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11085710/logo-dot_esports-h-white.png 300w, https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11085710/logo-dot_esports-h-white.png 1056w" sizes="(max-width: 767px) 300px, 1056px" src="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11085710/logo-dot_esports-h-white.png" alt="Dot Esports" /></a><div class="nav-icon-container"><div class="nav-icon tw-mdl-close active"><span></span><span></span><span></span></div></div></div><nav><ul id="menu-top-menu" class="sf-mobile-menu clearfix"><li id="menu-item-1433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1433"><a href="https://dotesports.com/league-of-legends">LoL</a></li><li id="menu-item-1434" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1434"><a href="https://dotesports.com/overwatch">Overwatch</a></li><li id="menu-item-1435" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1435"><a href="https://dotesports.com/counter-strike">CS:GO</a></li><li id="menu-item-1436" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1436"><a href="https://dotesports.com/hearthstone">Hearthstone</a></li><li id="menu-item-1437" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1437"><a href="https://dotesports.com/dota-2">Dota 2</a></li><li id="menu-item-1438" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1438"><a href="https://dotesports.com/call-of-duty">Call of Duty</a></li><li id="menu-item-108515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108515"><a href="https://dotesports.com/apex-legends">Apex Legends</a></li><li id="menu-item-1439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1439"><a href="https://dotesports.com/fortnite">Fortnite</a></li><li id="menu-item-39274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39274"><a href="#">More</a><ul class="sub-menu"><li id="menu-item-127962" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-127962"><a href="https://dotesports.com/oceania">Oceania</a></li><li id="menu-item-39464" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39464"><a href="https://dotesports.com/pubg">PUBG</a></li><li id="menu-item-118580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118580"><a href="https://dotesports.com/rainbow-6">Rainbow 6</a></li><li id="menu-item-39275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39275"><a href="https://dotesports.com/business">Business</a></li><li id="menu-item-39276" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39276"><a href="https://dotesports.com/culture">Culture</a></li><li id="menu-item-39281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39281"><a href="https://dotesports.com/br/?noredirect=pt_BR">Ir para o Dot Esports Brasil</a></li><li id="menu-item-39282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39282"><a href="https://dotesports.com/es/?noredirect=es_ES">Ir a Dot Esports Espanol</a></li><li id="menu-item-39312" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39312"><a href="https://dotesports.com/privacy">Privacy Policy</a></li><li id="menu-item-39393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39393"><a href="https://dotesports.com/about">About</a></li></ul></li></ul></nav></div><div class="tw-mdl-overlay-close"></div><div class="theme-layout"><header class="header-area"><div id="sticky-top" class="sticky-top d-lg-none d-xl-block text-center"></div><div class="tw-menu-container container"><div class="tw-header-meta"><div class="tw-logo"><a class="logo " href="https://dotesports.com/"><img class="logo-img" srcset="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11085710/logo-dot_esports-h-white.png 300w, https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11085710/logo-dot_esports-h-white.png 1056w" sizes="(max-width: 767px) 300px, 1056px" src="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2018/08/11085710/logo-dot_esports-h-white.png" alt="Dot Esports" /></a></div></div><nav class="tw-menu"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1433"><a href="https://dotesports.com/league-of-legends">LoL</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1434"><a href="https://dotesports.com/overwatch">Overwatch</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1435"><a href="https://dotesports.com/counter-strike">CS:GO</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1436"><a href="https://dotesports.com/hearthstone">Hearthstone</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1437"><a href="https://dotesports.com/dota-2">Dota 2</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1438"><a href="https://dotesports.com/call-of-duty">Call of Duty</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108515"><a href="https://dotesports.com/apex-legends">Apex Legends</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1439"><a href="https://dotesports.com/fortnite">Fortnite</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39274"><a href="#">More</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-127962"><a href="https://dotesports.com/oceania">Oceania</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39464"><a href="https://dotesports.com/pubg">PUBG</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118580"><a href="https://dotesports.com/rainbow-6">Rainbow 6</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39275"><a href="https://dotesports.com/business">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39276"><a href="https://dotesports.com/culture">Culture</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39281"><a href="https://dotesports.com/br/?noredirect=pt_BR">Ir para o Dot Esports Brasil</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39282"><a href="https://dotesports.com/es/?noredirect=es_ES">Ir a Dot Esports Espanol</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39312"><a href="https://dotesports.com/privacy">Privacy Policy</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39393"><a href="https://dotesports.com/about">About</a></li></ul></li></ul></nav><div class="tw-header-meta"><form method="get" class="searchform" action="https://dotesports.com/" ><div class="input"><input type="text" value="" name="s" placeholder="Search..." /><i class="ion-search tw-search-icon"></i></div></form><div class="nav-icon tw-modal-btn" data-modal=".tw-mobile-menu"> <span></span> <span></span> <span></span></div></div></div></header><div class="proper-ad-unit takeover"><div id="proper-ad-dotesports_skin"> <script>window.propertag.cmd.push(function() { proper_display('dotesports_skin'); } )</script> </div></div><div class="proper-ad-unit top-billboard proper-ad-top"></div><div id="top-spacing-holder"></div><div class="rever-container container"><div class="row"><div class="content-area right-sidebar col-md-8"><div class="single-content"><div id="ajax-load-more" class="ajax-load-more-wrap infinite classic alm-layouts"  data-alm-id="" data-canonical-url="https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon" data-slug="call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon" data-post-id="153840" ><div class="alm-listing alm-ajax" data-single-post="true" data-single-post-id="153840" data-single-post-order="previous" data-single-post-taxonomy="category" data-single-post-title-template="{post-title} | {site-title}" data-single-post-site-title="Dot Esports" data-single-post-site-tagline="" data-single-post-scroll="false" data-single-post-scrolltop="30" data-single-post-controls="1" data-single-post-pageview="false" data-container-type="div" data-repeater="default" data-theme-repeater="single.php" data-post-type="post" data-order="DESC" data-orderby="date" data-offset="0" data-posts-per-page="10" data-scroll="true" data-scroll-distance="-1000" data-max-pages="0" data-pause-override="false" data-pause="false" data-button-label="Older Posts" data-transition="fade" data-images-loaded="false"><div class="alm-reveal alm-single-post post-153840" data-url="https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon" data-title="Call of Duty Mobile soft-launched in Australia and Canada with more regions coming soon" data-id="153840" data-page="0"><article class="single post-153840 post type-post status-publish format-standard has-post-thumbnail hentry category-call-of-duty category-mobile"><div class="tw-date-category"> <span class="entry-date"> <a href="https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon"> 19 mins ago </a> </span> <span class="entry-category-tags"> Call of Duty </span></div><h1 class="entry-title">Call of Duty Mobile soft-launched in Australia and Canada with more regions coming soon</h1><div class="entry-excerpt"><p>The game has finally been released.</p></div><div class="tw-meta"> <span class="entry-author"> <img alt src="https://secure.gravatar.com/avatar/871442c3d1eb769ff2ebd91dcda9c67e?s=40&#038;d=https%3A%2F%2Fdotesports-media.nyc3.cdn.digitaloceanspaces.com%2Fwp-content%2Fuploads%2F2018%2F08%2F11090518%2Flogo-dot_esports-mark-black-1.png&#038;r=g" class="avatar avatar-40 photo jetpack-lazy-image" height="40" width="40" data-lazy-srcset="https://secure.gravatar.com/avatar/871442c3d1eb769ff2ebd91dcda9c67e?s=80&#038;d=https%3A%2F%2Fdotesports-media.nyc3.cdn.digitaloceanspaces.com%2Fwp-content%2Fuploads%2F2018%2F08%2F11090518%2Flogo-dot_esports-mark-black-1.png&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/871442c3d1eb769ff2ebd91dcda9c67e?s=40&amp;is-pending-load=1#038;d=https%3A%2F%2Fdotesports-media.nyc3.cdn.digitaloceanspaces.com%2Fwp-content%2Fuploads%2F2018%2F08%2F11090518%2Flogo-dot_esports-mark-black-1.png&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/871442c3d1eb769ff2ebd91dcda9c67e?s=40&#038;d=https%3A%2F%2Fdotesports-media.nyc3.cdn.digitaloceanspaces.com%2Fwp-content%2Fuploads%2F2018%2F08%2F11090518%2Flogo-dot_esports-mark-black-1.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/871442c3d1eb769ff2ebd91dcda9c67e?s=80&#038;d=https%3A%2F%2Fdotesports-media.nyc3.cdn.digitaloceanspaces.com%2Fwp-content%2Fuploads%2F2018%2F08%2F11090518%2Flogo-dot_esports-mark-black-1.png&#038;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></noscript><a href="https://dotesports.com/author/wasifahmed" title="Posts by Wasif Ahmed" class="author url fn" rel="author">Wasif Ahmed</a> </span></div><div class="entry-media single-media-thumb"><div class="tw-thumbnail"><div class="image-overlay"><a href="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2019/07/20205349/fgjh.jpg" title="Call of Duty Mobile soft-launched in Australia and Canada with more regions coming soon" class="overlay-icon"><img src="https://dotesports-media.nyc3.cdn.digitaloceanspaces.com/wp-content/uploads/2019/07/20205349/fgjh-770x433.jpg" alt="call of duty mobile"></a></div><span class="featured-image-caption">Image via Activision</span></div></div><div class="entry-content-container"><div class="entry-content"><p>Since <em>Call of Duty Mobile</em> was revealed last year, mobile gaming enthusiasts haven&#8217;t been able to contain their excitement for the hit franchise coming to mobile. After several beta launches for different countries around the world, the game has finally been soft-launched on Android and iOS for Canada and Australia. The launch will be expanding to other regions soon.</p><div class="proper-ad-unit"><div id="proper-ad-dotesports_content_1"> <script>window.propertag.cmd.push(function() { proper_display("dotesports_content_1"); } )</script> </div></div><p><em>Call of Duty Mobile</em> combines elements from across the <em>CoD </em>franchise and has maps from <em>CoD</em> titles like <em>Black Ops</em> and <em>Modern Warfare,</em> including Nuketown and Hijacked. The game is also releasing with a <a href="https://dotesports.com/call-of-duty/news/call-of-duty-mobile-beta-gets-a-battle-royale-mode-and-it-looks-amazing%ef%bb%bf" target="_blank" rel="noreferrer noopener" aria-label=" (opens in a new tab)">battle royale mode</a> that&#8217;s similar to Blackout in <em>Call of Duty: Black Ops 4</em>. In the multiplayer modes, the usual favorites like Team Deathmatch, Free-for-All, and Search and Destroy are present. There was also a zombie mode in the beta releases but it&#8217;s yet to be confirmed whether the present soft launch has it.</p><div class="mm-player"></div><p>Chris Plummer, the vice president of mobile at Activision, talked about game progression, items, and more in an <a href="https://blog.activision.com/call-of-duty/2019-07/Call-of-Duty-Mobile-Incoming-Intel-Player-Progression-and-Ranking-Questions-Answered" target="_blank" rel="noreferrer noopener" aria-label=" (opens in a new tab)">interview</a> published on the Activision blog.</p><p>Players will start from the rookie rank and progress all the way up to legendary. Each ranked match grants ranked points, which are based on the team&#8217;s victory and individual performance. &#8220;Players will earn awesome rewards as they progress through the ranks,&#8221; Plummer said. </p><div class="proper-ad-unit"><div id="proper-ad-dotesports_content_2"> <script>window.propertag.cmd.push(function() { proper_display("dotesports_content_2"); } )</script> </div></div><p>The freemium mobile first-person shooter (FPS) also has a Battle Pass, with a premium version that gives the players more rewards. Rank progression can be done through both battle royale and multiplayer so players can play the mode they enjoy the most.&nbsp;</p><p>Dates for the territory expansion still haven&#8217;t been released. The game, which hit 10 million pre-registrations in May, should slowly become available in the coming weeks.</p><div class="proper-ad-unit"><div id="proper-ad-dotesports_main_2"> <script>window.propertag.cmd.push(function() { proper_display("dotesports_main_2"); } )</script> </div></div><div class="clearfix"></div></div></div> <script type="text/javascript">jQuery.fn.almUrlUpdate = function(permalink, type) {
      if (type === 'single-post' && permalink === 'https://dotesports.com/news/call-of-duty-mobile-soft-launched-in-australia-and-canada-with-more-regions-coming-soon') {
        console.log('to infinity and beyond');
        setSidebarAffixHeight();
        // push new information to GTM
        dataLayer.push({
          'pagePostAuthor': 'Wasif Ahmed',
          'event': 'infinite-scroll-single'
        });
        // refresh ads
        if(jQuery.inArray( permalink, visitedURLs ) == -1){
          console.log('update ads');
          visitedURLs.push(permalink); 
          var stickyBottom = jQuery("#sticky-bottom");
          if (stickyBottom.css('display') == 'block' || stickyBottom.css('display') == 'flex') {
              refreshProperAd('dotesports_main_3');
          }else{
              refreshProperAd('dotesports_side_2');
              refreshProperAd('dotesports_side_3');
          }
        }
         //keywee pageview
         //kwa('sendPageView');
        
      }
    }</script> </article></div></div><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next">Older Posts</button></div></div></div></div><div class="sidebar-area col-md-4"><div class="sidebar-inner"><aside class="widget proper_media_ad_widget" id="proper_media_ad_widget-3"><div class="widget-item"><div class="proper-ad-unit"><div id="proper-ad-dotesports_side_1" data-properslot="dotesports_side_1"> <script>window.propertag.cmd.push(function() { proper_display("dotesports_side_1"); } )</script> </div></div></div></aside><aside class="widget popular-posts" id="wpp-15"><div class="widget-item"><h3 class="widget-title"><span>Trending Articles</span></h3> <script type="text/javascript">document.addEventListener('DOMContentLoaded', function() {
                    var wpp_widget_container = document.getElementById('wpp-15');

                    if ( 'undefined' != typeof WordPressPopularPosts ) {
                        WordPressPopularPosts.get(
                            wpp_params.ajax_url + 'widget',
                            'id=15',
                            function( response ){
                                wpp_widget_container.innerHTML += JSON.parse( response ).widget;

                                var event = null;

                                if ( 'function' === typeof(Event) ) {
                                    event = new Event( "wpp-onload", {"bubbles": true, "cancelable": false} );
                                } /* Fallback for older browsers */
                                else {
                                    if ( document.createEvent ) {
                                        event = document.createEvent('Event');
                                        event.initEvent( "wpp-onload", true, false );
                                    }
                                }

                                if ( event ) {
                                    wpp_widget_container.dispatchEvent( event );
                                }
                            }
                        );
                    }
                });</script> </div></aside><div id="sidebar-inner-affix-container" class="sidebar-inner-affix-container" style="will-change: min-height;"><div class="sidebar-inner-affix" style="will-change: min-height"><div class="sidebar-inner-affix-inner" style="will-change: position, transform;"><aside class="widget proper_media_ad_widget" id="proper_media_ad_widget-2"><div class="widget-item"><div class="proper-ad-unit"><div id="proper-ad-dotesports_side_2" data-properslot="dotesports_side_2"> <script>window.propertag.cmd.push(function() { proper_display("dotesports_side_2"); } )</script> </div></div></div></aside><aside class="widget proper_media_ad_widget" id="proper_media_ad_widget-8"><div class="widget-item"><div class="proper-ad-unit"><div id="proper-ad-dotesports_side_3" data-properslot="dotesports_side_3"> <script>window.propertag.cmd.push(function() { proper_display("dotesports_side_3"); } )</script> </div></div></div></aside></div></div></div></div></div></div></div><footer class="footer-area"><div class="container"><div class="tw-footer clearfix"><p class="copyright">&copy; 2019 Dot Esports</p></div></div></footer></div><div id="sticky-bottom" class="sticky-bottom d-lg-none text-center"></div><div class="pswp" tabindex="-1" role="dialog" aria-hidden="true"><div class="pswp__bg"></div><div class="pswp__scroll-wrap"><div class="pswp__banner"></div><div class="pswp__container"><div class="pswp__item"></div><div class="pswp__item"></div><div class="pswp__item"></div></div><div class="pswp__ui pswp__ui--hidden"><div class="pswp__top-bar"><div class="pswp__counter"></div> <button class="pswp__button pswp__button--close" title="Close (Esc)"></button> <button class="pswp__button pswp__button--share" title="Share"></button> <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button> <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button><div class="pswp__preloader"><div class="pswp__preloader__icn"><div class="pswp__preloader__cut"><div class="pswp__preloader__donut"></div></div></div></div></div><div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap"><div class="pswp__share-tooltip"></div></div> <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)"> </button> <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)"> </button><div class="pswp__caption"><div class="pswp__caption__center"></div></div></div></div></div> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WDR623V"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201929'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/superfish.min.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/fluidvids.min.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/libgif.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/rubbable.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/ResizeSensor.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/themes/rever/assets/js/sticky-sidebar.min.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=7.5.3'></script> <script type='text/javascript' src='https://dotesports.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/ajax-load-more/vendor/js/alm/legacy-callbacks.js?ver=5.2.2'></script> <script type='text/javascript'>var alm_localize = {"ajaxurl":"https:\/\/dotesports.com\/wp-admin\/admin-ajax.php","alm_nonce":"c4df4f4826","pluginurl":"https:\/\/dotesports.com\/wp-content\/plugins\/ajax-load-more","scrolltop":"false","display_results":"Showing {num} of {total} results","ajax_object":{"is_single":true,"is_singular":true}};
var ajax_load_more_vars = {"id":"ajax-load-more"};</script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=5.0.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/ajax-load-more-pro/pro/ajax-load-more-previous-post/js/alm-single-posts.min.js?ver=1.3.2'></script> <script type='text/javascript' src='https://dotesports.com/wp-content/plugins/ajax-load-more-pro/pro/ajax-load-more-seo/js/alm-seo.min.js?ver=1.9.0'></script> <script type='text/javascript' src='https://stats.wp.com/e-201929.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.5.3',blog:'151210721',post:'153840',tz:'-5',srv:'dotesports.com'} ]);
	_stq.push([ 'clickTrackerInit', '151210721', '153840' ]);</script> <script>setTimeout(function() {
        var stickySidebar = new StickySidebar('.sidebar-inner-affix', { 
            innerWrapperSelector: '.sidebar-inner-affix-inner',
            containerSelector: '.sidebar-inner-affix-container',
            topSpacing: 65,
        });
    }, 2000);</script> </body></html>