<!doctype html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="stylesheet" media="print" onload="this.onload=null;this.media='all';" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Montserrat%3A400%2C600%7CSource+Serif+Pro%3A400%2C500%2C600%2C700&amp;display=swap" /><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="preload" as="font" type="font/woff2" crossorigin href="https://cdn2.dotesports.com/wp-content/themes/dotesports-wordpress-theme/icons/font/dotesports.woff2?36239003"> <script id="gfc-snippet">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</script> <script>var special_ops=special_ops||{};</script> <script>special_ops.page_type = "home";</script> <script>special_ops.tags = ["drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back", "league-of-legends"];</script> <script>var propertag = propertag || {};
			propertag.cmd = propertag.cmd || [];
			(function() {
			var pm = document.createElement('script');
			pm.async = true; pm.type = 'text/javascript';
			var is_ssl = 'https:' == document.location.protocol;
			pm.src = (is_ssl ? 'https:' : 'http:') + '//global.proper.io/dotesports.min.js';
			var node = document.getElementsByTagName('script')[0];
			node.parentNode.insertBefore(pm, node);
			var gfc = document.getElementById('gfc-snippet');
			var node2 = document.getElementsByTagName('script')[0];
			node2.parentNode.insertBefore(gfc, node2);
			})();</script> <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://attractivecap.com/v2/0/rxmHiaPkl449pV8a-Atot7CEr2IMfoxYgUs1c1MyI4KXwccxK5vLskO9OGwxhEAqf4Q",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");</script> <script>var dataLayer = [{'is_usa':1, 'country_code':'US'}];</script>  <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//</script> 
 <style media="all">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</style><style media="screen">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</style><style media="print">@media print{.pmpro_a-print{display:none;position:absolute;left:-9999px}}</style><title>DRX’s Pyosik on his teammates: “They did say that they’re coming back, but the vibe was like they weren’t ever coming back” | Dot Esports</title><meta name="description" content="Hong &quot;Pyosik&quot; Chang-hyeon, the last remaining player of LCK team DragonX, poured his heart out in a recent livestream." /><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="DRX’s Pyosik on his teammates: “They did say that they’re coming back, but the vibe was like they weren’t ever coming back” | Dot Esports" /><meta property="og:description" content="Hong &quot;Pyosik&quot; Chang-hyeon, the last remaining player of LCK team DragonX, poured his heart out in a recent livestream." /><meta property="og:url" content="https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back" /><meta property="og:site_name" content="Dot Esports" /><meta property="article:publisher" content="https://www.facebook.com/DOTesports/" /><meta property="article:published_time" content="2020-11-17T09:25:41+00:00" /><meta property="article:modified_time" content="2020-11-17T09:25:44+00:00" /><meta property="og:image" content="https://cdn1.dotesports.com/wp-content/uploads/2020/11/17041617/50489805756_992294759f_k.jpg" /><meta property="og:image:width" content="2048" /><meta property="og:image:height" content="1432" /><meta property="fb:app_id" content="1218020374973612" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@Jeromehwh" /><meta name="twitter:site" content="@DotEsports" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://dotesports.com/#website","url":"https://dotesports.com/","name":"Dot Esports","description":"","potentialAction":[{"@type":"SearchAction","target":"https://dotesports.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back#primaryimage","inLanguage":"en-US","url":"https://cdn1.dotesports.com/wp-content/uploads/2020/11/17041617/50489805756_992294759f_k.jpg","width":2048,"height":1432,"caption":"Photo via Riot Games"},{"@type":"WebPage","@id":"https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back#webpage","url":"https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back","name":"DRX\u2019s Pyosik on his teammates: \u201cThey did say that they\u2019re coming back, but the vibe was like they weren\u2019t ever coming back\u201d | Dot Esports","isPartOf":{"@id":"https://dotesports.com/#website"},"primaryImageOfPage":{"@id":"https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back#primaryimage"},"datePublished":"2020-11-17T09:25:41+00:00","dateModified":"2020-11-17T09:25:44+00:00","author":{"@id":"https://dotesports.com/#/schema/person/b8e5468b24dc721f79902b817dc63e6d"},"description":"Hong \"Pyosik\" Chang-hyeon, the last remaining player of LCK team DragonX, poured his heart out in a recent livestream.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back"]}]},{"@type":"Person","@id":"https://dotesports.com/#/schema/person/b8e5468b24dc721f79902b817dc63e6d","name":"Jerome Heath","image":{"@type":"ImageObject","@id":"https://dotesports.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/d5edb482ebba235eb329b9ae50902d7d?s=96&d=mm&r=g","caption":"Jerome Heath"},"description":"Jerome is a freelance writer from the U.K.","sameAs":["https://twitter.com/Jeromehwh"]}]}</script> <link rel='dns-prefetch' href='//dotesports.com' /><link rel='dns-prefetch' href='//unpkg.com' /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Dot Esports &raquo; Feed" href="https://dotesports.com/feed" /> <script type='application/json' id='wpp-json'>{"sampling_active":1,"sampling_rate":100,"ajax_url":"https:\/\/dotesports.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":327020,"token":"a97790c014","lang":0,"debug":0}</script> <link rel="https://api.w.org/" href="https://dotesports.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dotesports.com/wp-json/wp/v2/posts/327020" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dotesports.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dotesports.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.5.3" /><link rel='shortlink' href='https://dotesports.com/?p=327020' /><link rel="alternate" type="application/json+oembed" href="https://dotesports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdotesports.com%2Fleague-of-legends%2Fnews%2Fdrxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back" /><link rel="alternate" type="text/xml+oembed" href="https://dotesports.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdotesports.com%2Fleague-of-legends%2Fnews%2Fdrxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back&#038;format=xml" />  <script type="application/ld+json">{"@context":"http:\/\/schema.org\/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/dotesports.com\/league-of-legends\/news\/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back"},"url":"https:\/\/dotesports.com\/league-of-legends\/news\/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back","headline":"DRX’s Pyosik on his teammates: “They did say that they’re coming back, but the vibe was like they...","datePublished":"2020-11-17T04:25:41-05:00","dateModified":"2020-11-17T04:25:44-05:00","publisher":{"@type":"Organization","@id":"https:\/\/dotesports.com\/#organization","name":"Dot Esports","logo":{"@type":"ImageObject","url":"https:\/\/dotesports-media.nyc3.cdn.digitaloceanspaces.com\/wp-content\/uploads\/2018\/12\/13191656\/dotesports-amp.png","width":600,"height":60}},"image":{"@type":"ImageObject","url":"https:\/\/cdn1.dotesports.com\/wp-content\/uploads\/2020\/11\/17041617\/50489805756_992294759f_k.jpg","width":2048,"height":1432},"articleSection":"League of Legends","description":"DragonX parted ways with Doran, Chovy,  Deft, and Keria on Nov. 16 following the team’s exit from Worlds 2020.","author":{"@type":"Person","name":"Jerome Heath","url":"https:\/\/dotesports.com\/author\/jeromeheath","description":"Jerome is a freelance writer from the U.K.","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/d5edb482ebba235eb329b9ae50902d7d?s=96&d=mm&r=g","height":96,"width":96},"sameAs":["https:\/\/twitter.com\/Jeromehwh"]}}</script>  <script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//
	var dataLayer_content = {"siteID":"1","siteName":"Dot Esports","visitorLoginState":"logged-out","pageTitle":"DRX’s Pyosik on his teammates: “They did say that they’re coming back, but the vibe was like they weren’t ever coming back” | Dot Esports","pagePostType":"post","pagePostType2":"single-post","pageCategory":["league-of-legends"],"pagePostAuthorID":1720,"pagePostAuthor":"Jerome Heath","pagePostDate":"November 17, 2020","pagePostDateYear":"2020","pagePostDateMonth":"11","pagePostDateDay":"17","deviceType":"desktop","deviceManufacturer":"","deviceModel":"","postID":327020,"postFormat":"standard"};
	dataLayer.push( dataLayer_content );//</script> <script data-cfasync="false">//
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WDR623V');//</script> <link rel="amphtml" href="https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back/amp"><link rel="icon" href="https://cdn1.dotesports.com/wp-content/uploads/2020/08/05202510/cropped-black-white-dotlogo-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://cdn1.dotesports.com/wp-content/uploads/2020/08/05202510/cropped-black-white-dotlogo-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://cdn1.dotesports.com/wp-content/uploads/2020/08/05202510/cropped-black-white-dotlogo-1-180x180.png" /><meta name="msapplication-TileImage" content="https://cdn1.dotesports.com/wp-content/uploads/2020/08/05202510/cropped-black-white-dotlogo-1-270x270.png" /><style type="text/css" id="wp-custom-css">/* Temporay CSS */

.settings-table-style table {
    font-size: smaller;
    border-spacing: 0;
    width: 100%;
    text-align: left;
}

.settings-table-style table td {
    text-align: left;
    padding: 8px;
		border: 1px solid #e7e7e7;
}

.settings-table-style table tr:nth-child(even) {
    background-color: #f2f2f2;
}

.settings-table-style table th {
    padding-top: 11px;
    padding-bottom: 11px;
    background-color: #000;
    color: #fff;
    padding: 8px;
	  border: 1px solid #e7e7e7;
}

/* use caption heading in settings table */

.settings-table-style.use-caption-heading{ /* if using postion relative and figcaption as header of table */
    position: relative;
}

.settings-table-style.use-caption-heading table{ 
    margin-top: 40px;
}
  
.settings-table-style.use-caption-heading figcaption { /* if using postion relative and figcaption as header of table */
  padding: 10px;
  background: #000;
  color: #fff;
  position: absolute;
  top: 0;
  width: 100%;
}</style></head><body class="post-template-default single single-post postid-327020 single-format-standard pmpro-body-has-access no-sidebar"><div id="page" class="site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header"><div id="sticky-top"></div><div class="container"><div class="site-branding"> <a href="/"> <picture> <source media="(min-width: 769px)" srcset="https://cdn1.dotesports.com/wp-content/uploads/2018/08/11085710/logo-dot_esports-h-white-300x82.png"> <source media="(max-width: 768px)" srcset="https://cdn1.dotesports.com/wp-content/uploads/2020/08/05102536/logo-dot_esports-mark-white-150x150.png"> <img src="https://cdn1.dotesports.com/wp-content/uploads/2020/08/05102536/logo-dot_esports-mark-white-150x150.png"> </picture> </a></div><nav id="site-navigation" class="main-navigation"> <i class="menu-toggle icon-menu" aria-controls="primary-menu" aria-expanded="false" role="button"></i><div class="menu-top-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-1433" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1433"><a href="https://dotesports.com/league-of-legends">LoL</a></li><li id="menu-item-1434" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1434"><a href="https://dotesports.com/overwatch">Overwatch</a></li><li id="menu-item-1435" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1435"><a href="https://dotesports.com/counter-strike">CS:GO</a></li><li id="menu-item-228651" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-228651"><a href="https://dotesports.com/valorant">Valorant</a></li><li id="menu-item-1437" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1437"><a href="https://dotesports.com/dota-2">Dota 2</a></li><li id="menu-item-1438" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1438"><a href="https://dotesports.com/call-of-duty">CoD</a></li><li id="menu-item-108515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108515"><a href="https://dotesports.com/apex-legends">Apex Legends</a></li><li id="menu-item-1439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1439"><a href="https://dotesports.com/fortnite">Fortnite</a></li><li id="menu-item-39274" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-39274"><a href="#">More</a><ul class="sub-menu"><li id="menu-item-247117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-247117"><a href="https://dotesports.com/hardware">Hardware</a></li><li id="menu-item-233884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-233884"><a href="https://dotesports.com/hearthstone">Hearthstone</a></li><li id="menu-item-39464" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39464"><a href="https://dotesports.com/pubg">PUBG</a></li><li id="menu-item-203427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-203427"><a href="https://dotesports.com/tft">Teamfight Tactics</a></li><li id="menu-item-203426" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-203426"><a href="https://dotesports.com/mtg">MTG</a></li><li id="menu-item-118580" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118580"><a href="https://dotesports.com/rainbow-6">Rainbow 6</a></li><li id="menu-item-127962" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-127962"><a href="https://dotesports.com/oceania">Oceania</a></li><li id="menu-item-39275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39275"><a href="https://dotesports.com/business">Business</a></li><li id="menu-item-39281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39281"><a href="https://dotesports.com/br/?noredirect=pt_BR">Ir para o Dot Esports Brasil</a></li><li id="menu-item-39282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39282"><a href="https://dotesports.com/es/?noredirect=es_ES">Ir a Dot Esports Espanol</a></li><li id="menu-item-279927" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-279927"><a href="https://dotesports.com/fr/">Dot Esports français</a></li><li id="menu-item-39312" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39312"><a href="https://dotesports.com/privacy">Privacy Policy</a></li><li id="menu-item-164596" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164596"><a href="https://dotesports.com/terms">Terms of Service</a></li><li id="menu-item-39393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-39393"><a href="https://dotesports.com/about">About</a></li></ul></li></ul></div><div class="site-header-right"><div class="site-header-notifs"> <i class="notifs-toggle icon-bell"></i><div class="notifs-popover popover"><div class="notifs-popover__title">Notifications</div><div class='onesignal-customlink-container'></div><div class="notifs-popover__categories"><div class="notifs-popover__subtitle">Categories</div><p class="notifs-popover__explainer"> You can choose which categories you want to be notified for.</p> <button class="notifs-popover__categoriesbutton"> Manage Categories </button></div></div></div><div class="site-header-search"> <i class="search-toggle icon-search"></i> <script>(function() {
      document.querySelector('.search-toggle').onclick = function() {
        if (!document.querySelector('.search-form').classList.contains('toggled')) {
          document.querySelectorAll('.popover').forEach(popover => popover.classList.remove('toggled'));
          document.querySelectorAll('.site-header i').forEach(icon => icon.classList.remove('toggled'));
          document.querySelector('.search-toggle').classList.add('toggled');
          document.querySelector('.search-form').classList.add('toggled');
        } else {
          document.querySelector('.search-toggle').classList.remove('toggled');
          document.querySelector('.search-form').classList.remove('toggled');
        }
      };
    })();</script> </div> <a class="site-header-auth logged-out red" href="/go-ad-free">Go Ad-Free</a> <a class="site-header-auth logged-out" href="/login">Login</a></div></nav><form role="search" method="get" class="search-form popover" action="/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search..." name="s"> </label></form></div></header><div id="content" class="site-wrapper"><div class="proper-ad-unit" id="siteskin"><div id="proper-ad-dotesports_skin"> <script>window.propertag.cmd.push(function() {
            proper_display('dotesports_skin');
          })</script> </div></div><div class="proper-ad-unit will-fixed" id="top-billboard"></div><div class="container"><div class="row site-content"><div id="primary" class="content-area col-lg-8"><main id="main" class="site-main"><div id="ajax-load-more" class="ajax-load-more-wrap infinite fading-circles alm-layouts"  data-alm-id="" data-canonical-url="https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back" data-slug="drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back" data-post-id="327020"  data-localized="ajax_load_more_vars"><style type="text/css">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</style><style type="text/css">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</style><div aria-live="polite" aria-atomic="true" class="alm-listing alm-ajax" data-cache="true" data-cache-id="60249327020" data-cache-path="https://dotesports.com/wp-content/uploads/alm-cache/" data-single-post="true" data-single-post-id="327020" data-single-post-order="previous" data-single-post-taxonomy="category" data-single-post-title-template="{post-title} | {site-title}" data-single-post-site-title="Dot Esports" data-single-post-site-tagline="" data-single-post-scroll="false" data-single-post-scrolltop="500" data-single-post-controls="1" data-single-post-progress-bar="" data-single-post-pageview="false" data-container-type="div" data-theme-repeater="single.php" data-post-type="post" data-post-format="standard" data-order="DESC" data-orderby="date" data-offset="0" data-posts-per-page="1" data-scroll="true" data-scroll-distance="-1000" data-max-pages="0" data-pause-override="false" data-pause="false" data-button-label="Older Posts"><div class="alm-reveal alm-single-post post-327020" data-url="https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back" data-title="DRX’s Pyosik on his teammates: “They did say that they’re coming back, but the vibe was like they weren’t ever coming back”" data-id="327020" data-page="0"><article id="post-327020" data-article-type="News" data-article-categories="League of Legends" class="post-327020 post type-post status-publish format-standard has-post-thumbnail hentry category-league-of-legends pmpro-has-access"><header class="entry-header"><div class="entry-topline"> <span class="posted-on"><time class="entry-date published" datetime="2020-11-17T04:25:41-05:00">Nov 17, 2020 4:25 am</time><time class="updated" datetime="November 17, 2020, 04:25 GMT-0500">2020-11-17T04:25:44-05:00</time></span><ul class="post-categories"><li><a href="https://dotesports.com/league-of-legends" rel="category tag">League of Legends</a></li></ul></div><h1 class="entry-title">DRX’s Pyosik on his teammates: “They did say that they’re coming back, but the vibe was like they weren’t ever coming back”</h1><p class="entry-lede"> DragonX parted ways with Doran, Chovy,  Deft, and Keria on Nov. 16 following the team’s exit from Worlds 2020.</p><div class="byline"> <a class="avatar-wrap url fn n" href="https://dotesports.com/author/jeromeheath"> <img alt='' src='https://secure.gravatar.com/avatar/d5edb482ebba235eb329b9ae50902d7d?s=64&#038;d=https%3A%2F%2Fcdn1.dotesports.com%2Fwp-content%2Fuploads%2F2018%2F08%2F11090518%2Flogo-dot_esports-mark-black-1.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/d5edb482ebba235eb329b9ae50902d7d?s=128&#038;d=https%3A%2F%2Fcdn1.dotesports.com%2Fwp-content%2Fuploads%2F2018%2F08%2F11090518%2Flogo-dot_esports-mark-black-1.png&#038;r=g 2x' class='avatar avatar-64 photo' height='64' width='64' /> </a> <span> <a href="https://dotesports.com/author/jeromeheath" title="Posts by Jerome Heath" class="author url fn" rel="author">Jerome Heath</a> </span></div></header><div class="entry-lead-media"><div class="post-thumbnail"> <img width="2048" height="1432" src="https://cdn1.dotesports.com/wp-content/uploads/2020/11/17041617/50489805756_992294759f_k.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="https://cdn1.dotesports.com/wp-content/uploads/2020/11/17041617/50489805756_992294759f_k.jpg 2048w, https://cdn1.dotesports.com/wp-content/uploads/2020/11/17041617/50489805756_992294759f_k-300x210.jpg 300w, https://cdn1.dotesports.com/wp-content/uploads/2020/11/17041617/50489805756_992294759f_k-1024x716.jpg 1024w, https://cdn1.dotesports.com/wp-content/uploads/2020/11/17041617/50489805756_992294759f_k-768x537.jpg 768w, https://cdn1.dotesports.com/wp-content/uploads/2020/11/17041617/50489805756_992294759f_k-1536x1074.jpg 1536w" sizes="(max-width: 2048px) 100vw, 2048px" /><div class="caption"> Photo via Riot Games</div></div></div><div class="entry-content"><div class="proper-ad-insert"></div><p>Hong &#8220;Pyosik&#8221; Chang-hyeon, the last remaining player of the LCK&#8217;s DragonX, poured his heart out in a <a href="https://twitter.com/AshleyKang/status/1328607817624915968">recent livestream</a>, recollecting Doran, Chovy, Deft, and Keria’s departure from the team.</p><script type="text/javascript" language="javascript" src="https://live.sekindo.com/live/liveView.php?s=103704&#038;cbuster=[CACHE_BUSTER]&#038;pubUrl=[PAGE_URL_ENCODED]&#038;subId=[SUBID_ENCODED]&#038;x=[WIDTH]&#038;y=[HEIGHT]"></script> <p>“At the very end, they all said they’re leaving,” Pyosik said according to a translation by Korizon journalist <a href="https://twitter.com/AshleyKang/status/1328607817624915968">Ashley Kang</a>. “They started packing, so I asked them are you coming back? They did say that they’re coming back, but the vibe was like they weren’t ever coming back.”</p><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Pyosik, the only remaining player on the 2020 <a href="https://twitter.com/DRXGlobal?ref_src=twsrc%5Etfw">@DRXGlobal</a> main roster went on stream:<br><br>&quot;I&#39;m just regretful that I didn&#39;t do better for [my teammates].<br><br>*blacks the screen out*<br><br>At the very end. They suddenly all said, they&#39;re leaving. They started packing. So I asked &#8230;&quot; (cont) <a href="https://t.co/iUzCDiIgpS">pic.twitter.com/iUzCDiIgpS</a></p>&mdash; Ashley Kang #Worlds2020 (@AshleyKang) <a href="https://twitter.com/AshleyKang/status/1328607817624915968?ref_src=twsrc%5Etfw">November 17, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><p>DRX, despite an encouraging performance in the 2020 LCK Summer Split, fell short at the <em>League of Legends</em> World Championship in Shanghai, losing 3-0 to DAMWON Gaming in the quarterfinals.</p><p>Rookie Pyosik had moments of brilliance throughout the tournament, going toe-to-toe with the LPL’s Top Esports in the group stage, but DRX was inevitably outmatched by DAMWON on almost every front. </p><div class="proper-ad-insert"></div><p><a href="https://dotesports.com/league-of-legends/news/drx-parts-ways-with-chovy-doran-deft-and-keria">DRX parted ways</a> with top laner Doran, mid laner Chovy, ADC Deft, and support Keria on Nov. 16 following the team’s exit from Worlds 2020.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</p><p>“In their rooms, they were packing everything into boxes,” Pyosik said on his stream. “So I turned the lights off, flipped the boxes upside down, I threw their clothes onto the bed.”</p><p>“I said, “Don’t go, stay one more day. Please.” I was half-joking but half-serious. I thought, if I didn’t do that, everything would get too sad. I only have memories of being at the receiving end when it came to them.”</p><div class="proper-ad-insert"></div><p>With the 2021 LCK season fast approaching, DRX will almost certainly build its roster around 20-year-old jungler Pyosik, taking a new direction for the new year.</p><p>Where Pyosik’s former teammates will go next remains to be seen. </p></p><div class="proper-ad-insert"></div><interaction data-token="5d15dd918c697d0c5dba1c57" data-context="true" data-tags="" data-fallback="true"></interaction></div></article> <script type="text/javascript">window.propertag.cmd.push(function() { properBuildSlots() });</script> <script type="text/javascript">window.almUrlUpdate = function(permalink, type) {
        if (type === 'single-post' && permalink === 'https://dotesports.com/league-of-legends/news/drxs-pyosik-on-his-teammates-they-did-say-that-theyre-coming-back-but-the-vibe-was-like-they-werent-ever-coming-back') {
            console.log('almUrlUpdate');
            
            // load new ads
            window.propertag.cmd.push(function() { properInfNewPage() });

            // refresh mobile sticky ad
            window.propertag.cmd.push(function() { ProperMedia.ad_project.refreshSlotByName('dotesports_main_3') });

            if (window.dataLayer !== undefined ) {
                // push new information to GTM
                dataLayer.push({
                    'pagePostAuthor': "Jerome Heath",
                    'pageTitle': "DRX’s Pyosik on his teammates: “They did say that they’re coming back, but the vibe was like they weren’t ever coming back”",
                    'pagePostDate': 'November 17, 2020',
                    'articleType': 'News',
                    'articleCategories' : 'League of Legends',
                    'event': 'infinite-scroll-single'
                });
            }
            
            // init LUX again
            if (window.LUX) {
                window.LUX.init();
            }
        }
    }</script> <script type="text/javascript">window.almComplete = undefined;
	window.almComplete = function(alm) {
		console.log('almComplete', alm);
		if (loadCustomCarousel !== undefined) {
            loadCustomCarousel(); 
		}		
		if (window.addStickySidebar !== undefined && alm.el) {
            var matches = alm.el.className.match(/post-(\d+)/);
            var postId = matches[1]
            window.addStickySidebar(postId, alm.page)
		}
	};</script></div></div><div class="alm-btn-wrap" style="visibility: hidden;"><button class="alm-load-more-btn more " rel="next">Older Posts</button></div></div></main></div><aside id="secondary" class="widget-area d-none d-lg-block col-lg-4"><div id="nonsticky-sidebar"><aside class="widget_text widget widget_custom_html" id="custom_html-59"><div class="widget_text widget-item"><div class="textwidget custom-html-widget"><div class="proper-ad-insert-side-1"></div></div></div></aside><aside class="widget popular-posts" id="wpp-15"><div class="widget-item"><h3 class="widget-title"><span>Trending Articles</span></h3><ul class="wpp-list"><li><a href="https://dotesports.com/call-of-duty/news/nadeshot-calls-on-treyarch-to-dial-back-skill-based-matchmaking-in-call-of-duty-black-ops-cold-war" class="wpp-post-title" title="Nadeshot calls on Treyarch to &quot;[dial] back&quot; skill-based matchmaking in Call of Duty: Black Ops Cold War" target="_self">Nadeshot calls on Treyarch to "[dial] back" skill-based matchmaking in Call of Duty: Black Ops Cold War</a><div class="wpp-meta post-stats"><span class="wpp-author"><a href="https://dotesports.com/author/jalenlopez">Jalen Lopez</a></span> - <span class="wpp-date">November 15, 2020</span></div></li><li><a href="https://dotesports.com/league-of-legends/news/cloud9-reportedly-reaches-agreement-to-acquire-perkz-from-g2-esports" class="wpp-post-title" title="Cloud9 reportedly reaches agreement to acquire Perkz from G2 Esports" target="_self">Cloud9 reportedly reaches agreement to acquire Perkz from G2 Esports</a><div class="wpp-meta post-stats"><span class="wpp-author"><a href="https://dotesports.com/author/michaelkelly">Michael Kelly</a></span> - <span class="wpp-date">November 12, 2020</span></div></li><li><a href="https://dotesports.com/league-of-legends/news/riot-to-deploy-league-preseason-balance-hotfix-for-viktor-nerf-kassadin-buff-and-a-slew-of-items" class="wpp-post-title" title="Riot to deploy League preseason balance hotfix for Viktor nerf, Kassadin buff, and a slew of items" target="_self">Riot to deploy League preseason balance hotfix for Viktor nerf, Kassadin buff, and a slew of items</a><div class="wpp-meta post-stats"><span class="wpp-author"><a href="https://dotesports.com/author/andreasstavropoulos">Andreas Stavropoulos</a></span> - <span class="wpp-date">November 12, 2020</span></div></li><li><a href="https://dotesports.com/league-of-legends/news/a-number-of-league-champs-join-the-space-fight-with-new-cosmic-skins-including-skarner-hecarim-varus-and-nidalee" class="wpp-post-title" title="A number of League champs join the space fight with new Cosmic skins, including Skarner, Hecarim, Varus, and Nidalee" target="_self">A number of League champs join the space fight with new Cosmic skins, including Skarner, Hecarim, Varus, and Nidalee</a><div class="wpp-meta post-stats"><span class="wpp-author"><a href="https://dotesports.com/author/andreasstavropoulos">Andreas Stavropoulos</a></span> - <span class="wpp-date">November 10, 2020</span></div></li><li><a href="https://dotesports.com/apex-legends/news/respawn-to-make-apexs-season-7-challenges-easier-and-grant-all-players-10-free-battle-pass-levels" class="wpp-post-title" title="Respawn to make Apex&#039;s season 7 challenges easier and grant all players 10 free battle pass levels" target="_self">Respawn to make Apex's season 7 challenges easier and grant all players 10 free battle pass levels</a><div class="wpp-meta post-stats"><span class="wpp-author"><a href="https://dotesports.com/author/andreasstavropoulos">Andreas Stavropoulos</a></span> - <span class="wpp-date">November 10, 2020</span></div></li></ul></div></aside></div><div id="sticky-sidebar-wrapper" class="sticky-sidebar-wrapper"><div id="sticky-sidebar" class="sticky-sidebar"><div class="sticky-sidebar__inner"><aside class="widget_text widget widget_custom_html" id="custom_html-61"><div class="widget_text widget-item"><div class="textwidget custom-html-widget"><div class="proper-ad-insert-side-2"></div></div></div></aside><aside class="widget_text widget widget_custom_html" id="custom_html-60"><div class="widget_text widget-item"><div class="textwidget custom-html-widget"><div class="proper-ad-insert-side-3"></div></div></div></aside></div></div></div></aside> <script type="application/javascript">window.addStickySidebar = function(postId, index) {
			if (!postId || window.initialiseStickySidebar === undefined) return;
			(function () {
					var initialStickySidebar = document.getElementById('sticky-sidebar-wrapper');
					var newElement = document.createElement('div');
					newElement.innerHTML = '<div class="sticky-sidebar-wrapper"><div class="sticky-sidebar"><div class="sticky-sidebar__inner"><aside class="widget_text widget widget_custom_html" id="custom_html-61"><div class="widget_text widget-item"><div class="textwidget custom-html-widget"><div class="proper-ad-insert-side-2"><\/div><\/div><\/div><\/aside><aside class="widget_text widget widget_custom_html" id="custom_html-60"><div class="widget_text widget-item"><div class="textwidget custom-html-widget"><div class="proper-ad-insert-side-3"><\/div><\/div><\/div><\/aside><\/div><\/div><\/div>';
					var newStickySidebar = newElement.firstChild;

					// tag sidebar with post ids
					newStickySidebar.classList.add('post-' + postId);
					newStickySidebar.querySelector('.sticky-sidebar').classList.add('post-' + postId);
					newStickySidebar.querySelector('.sticky-sidebar__inner').classList.add('post-' + postId);		

					initialStickySidebar.parentNode.appendChild(newStickySidebar);

					window.initialiseStickySidebar(postId);
			})();
	}</script> </div></div></div><footer id="colophon" class="site-footer"><div class="site-info container"><p class="site-copyright"> &copy; 2020 Dot Esports</p></div></footer></div><div id="sticky-bottom"></div><div class="popup" id="newsletter-modal"><div class="popup-content"><div class="popup-image"></div><div class="popup-text"> <span id="newsletter-modal-close" class="popup-close">x</span><div class="popup-logo"></div><h2 class="popup-title">Get League news delivered every week</h3><p class="popup-hook"> Dot Esports League of Legends newsletter</p><form> <input type="hidden" name="nlang" value=""> <input type="hidden" name="nl[]" value="1"> <input type="email" name="ne"  placeholder="Enter your email address" required> <a class="popup-privacy" target="_blank" href="https://dotesports.com/privacy">By continuing, you accept the privacy policy</a> <input type="submit" value="Subscribe"></form><div class="popup-messages"><p class="popup-success"> Check your inbox for a confirmation email!</p><p class="popup-error"> Something went wrong, please try again.</p></div></div></div></div><div class="pswp" tabindex="-1" role="dialog" aria-hidden="true"><div class="pswp__bg"></div><div class="pswp__scroll-wrap"><div class="pswp__banner"></div><div class="pswp__container"><div class="pswp__item"></div><div class="pswp__item"></div><div class="pswp__item"></div></div><div class="pswp__ui pswp__ui--hidden"><div class="pswp__top-bar"><div class="pswp__counter"></div> <button class="pswp__button pswp__button--close" title="Close (Esc)"></button> <button class="pswp__button pswp__button--share" title="Share"></button> <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button> <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button><div class="pswp__preloader"><div class="pswp__preloader__icn"><div class="pswp__preloader__cut"><div class="pswp__preloader__donut"></div></div></div></div></div><div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap"><div class="pswp__share-tooltip"></div></div> <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)"> </button> <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)"> </button><div class="pswp__caption"><div class="pswp__caption__center"></div></div></div></div></div> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WDR623V"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>  <script type='text/javascript' id='dotgallery-js-extra'>var mobileCarouselAd = "<div id=\"proper-ad-dotesports_content_6\" data-properslot=\"dotesports_content_6\"><\/div>";
var desktopCarouselAd = "<div id=\"proper-ad-dotesports_content_6\" data-properslot=\"dotesports_content_6\"><\/div>";</script> <script type='text/javascript' src='https://unpkg.com/css-element-queries@1.2.3/src/ResizeSensor.js' id='dotesports-resizesensorjs-js'></script> <script type='text/javascript' src='https://unpkg.com/sticky-sidebar@3.3.1/dist/sticky-sidebar.min.js' id='dotesports-stickysidebarjs-js'></script> <script type='text/javascript' id='ajax-load-more-js-extra'>var alm_localize = {"ajaxurl":"https:\/\/dotesports.com\/wp-admin\/admin-ajax.php","alm_nonce":"435723fdd5","rest_api":"https:\/\/dotesports.com\/wp-json\/","rest_nonce":"a97790c014","pluginurl":"https:\/\/dotesports.com\/wp-content\/plugins\/ajax-load-more","speed":"200","ga_debug":"false","results_text":"Viewing {post_count} of {total_posts} results.","no_results_text":"No results found.","alm_debug":"","a11y_focus":"1"};
var ajax_load_more_vars = {"id":"ajax-load-more"};</script> <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async=""></script> <script>window.OneSignal = window.OneSignal || [];
  OneSignal.push(function() {
    OneSignal.init({
			appId: "e122ef3f-6fd5-4e43-90a4-62a77b566a57",
			safari_web_id: "web.com.dotesports",
      promptOptions: {
				customlink: {
					enabled: true, /* Required to use the Custom Link */
					style: "button", /* Has value of 'button' or 'link' */
					size: "medium", /* One of 'small', 'medium', or 'large' */
					color: {
						button: '#df2940', /* Color of the button background if style = "button" */
						text: '#FFFFFF', /* Color of the prompt's text */
					},
					text: {
						subscribe: "Subscribe", /* Prompt's text when not subscribed */
						unsubscribe: "Unsubscribe", /* Prompt's text when subscribed */
						explanation: "Get the latest news from the games that matter to you.", /* Optional text appearing before the prompt button */
					},
					unsubscribeEnabled: true, /* Controls whether the prompt is visible after subscription */
				},
        slidedown: {
          enabled: true,
          autoPrompt: true,
          timeDelay: 15,
          pageViews: 1,
          actionMessage: "We'd like to show you notifications for the latest news and updates.",
					acceptButtonText: "ALLOW",
					cancelButtonText: "No Thanks",
					categories: {
						updateMessage: "Would you like to update your notification preferences?",
						positiveUpdateButton: "UPDATE",
						negativeUpdateButton: "No Thanks",
						tags: [
							{
								tag: 'league-of-legends',
								label: "League of Legends",
							},
							{
								tag: 'valorant',
								label: "VALORANT",
							},
							{
								tag: 'dota-2',
								label: "Dota 2",
							},
							{
								tag: 'counter-strike',
								label: "CS:GO",
							},
							{
								tag: 'overwatch',
								label: "Overwatch",
							},
							{
								tag: 'call-of-duty',
								label: "Call of Duty",
							},
						],
					},
        }
      }
    });
  });</script> <script defer src="//cdn2.dotesports.com/wp-content/cache/autoptimize/1/js/autoptimize_19a93c21943bf825f68d1aa877fe0297.js"></script></body></html>